Napkin fails to launch due to missing .dylib


#21

@casi I’ve just pushed a fix to the main downloads page, napkin is now able to find the previously missing libfreetype.dylib: http://napframework.com/NAP-0.2.3-macOS.zip

Let me know how it works out!


#22

Great, it works with this one! Thank you.


#23

I’m still having an issue that looks very similar.

I have a brand new download of NAP 0.2.3 on my Mac, but launching Napkin always fails with the error:

./napkin                                         stephen@Stephens-MacBook-Pro
dyld: Library not loaded: @rpath/QtOpenGL.framework/Versions/5/QtOpenGL
  Referenced from: /Users/stephen/NAP-0.2.3-macOS/projects/stephendemo/bin/Clang-x86_64-Debug/./napkin
 Reason: image not found
[1]    2748 abort      ./napkin

It’s possible that some other devleopment tools/libraries installed on my system Mojave 10.14.3 (18D109)) are making path resolution problems?.


#24

@chris would you have any ideas about this? I am currently giving nap trainings at random studios and @steveb is one of the developers learning NAP, so it would be great if he could get napkin to work. He is running the latest package download for OSX 0.2.3.


#25

That’s strange, I thought we were on top of these.

Is @steveb using the official release or something you’ve created @stijnvanbeek?

@stijnvanbeek are you running Mojave? Are you able to reproduce the issue (using the official release)?

We’ll soon be introducing a testing process that targets these dependency issues.


#26

I’m using a dead-standard release. I even tried using @stijnvanbeek 's own package (which obviously works on his machine, but not on mine).

So it’s something in my system configuration that presumably overrides the path resolution?


#27

Yeah, so I’d say you’re right; I think you’ve got an install of Qt on your system that’s getting picked up instead our version. I’d be curious to know what method you’ve used to install that other version of Qt so I can attempt to reproduce and fix the issue.

Unfortunately I won’t be able to do that until next week though. In the short term if you’re interested for a workaround to get you up and running you’d want to look at having that other install of Qt not be found. Temporarily renaming it might help, as of course would (temporarily) removing it.

Apologies for the trouble!


#28

@steve solved it by running “brew update gawk”… Does that ring any bell?


#29

So I’m presuming that @steveb had Qt installed via Homebrew and that updating awk somehow affected the relationship between NAP and Qt in Homebrew (or at least the OpenGL module).

@steveb are you able to confirm that you have Qt installed via Homebrew? Were you updating awk to try and resolve this issue? It would be great to find out a little more about this so we can try and avoid it happening again.

However it’s great that you’re up and running :grinning:


#30

Actually, I do not recall installing Qt through homebrew at all, and there is no evidence that I did. So I’m still a little unsure why this issue came up in the first place.

Good to be up and running again, though. :slight_smile: