Xcode 10.2 appears to break everything


#1

Unfortunately allowed a minor (10.1->10.2) Xcode update today and now NAP projects (including demos) can compile but always crash on run.


#2

Error is always:

error: memory read failed for 0x0 and Thread 1: EXC_BAD_ACCESS)


#3

Downgrading back to Xcode 10.1 “resolves” the problem. But might be good to look into this?


#4

Yes, this is something we need to look into, haven’t encountered it before.

The move to Mojave caused a lot of issues for a lot of others that use OpenGL, we resolved those but no idea what changed from version 10.1 to 10.2

Cheers Coen


#5

#6

“Thanks, Apple”. :face_with_raised_eyebrow:


#7

Yup, Apple officially deprecated OpenGL in Mojave:

“Apps built using OpenGL and OpenCL will continue to run in macOS 10.14, but these legacy technologies are deprecated in macOS 10.14. Games and graphics-intensive apps that use OpenGL should now adopt Metal. Similarly, apps that use OpenCL for computational tasks should now adopt Metal and Metal Performance Shaders,” the company noted.

Most modern games with 3D graphics are not hard coded using low-level OpenGL. Instead, developers make use of higher-level graphics “engine” frameworks such as Epic Games’ Unreal Engine 4; Blizzard’s WoW and SC2 Engine; or Unity Engine. Like Apple’s own higher level graphics frameworks such as SceneKit, SpriteKit and ARKit, these already make native use of Metal under the scenes.

Way to go, and Apple refuses to support the true OpenGL successor Vulkan, which we’d love to adopt, instead of writing specific render back-ends for every OS (DirectX, Vulkan and Metal), which is hard to do for a small company like us.

I recently dove into Vulkan and really like the design, more open, low level and therefore compact. Great multi-threading support and modern api design. Much more in line with DirectX, but works cross platform and has been adopted by Google to be their new back-end for their just announced streaming platform.

Apple is really making the lives more difficult for the more ‘advanced’ users, going into a direction I find more difficult to justify every single day. Also: nobody that I know uses Unreal Engine 4 on macOS, macOS has never been a gaming platform, but a creative platform.

Sorry for the rant :wink:


#8

Rant totally and utterly justified, Coen.
Jesus H. Christ this is so idiotic. For the first time since switching to Mac I’m considering opting out again with this kind of business ethic from Apple.
Ugh.


#9

Just ran into the same issue with Jerre, a new developer with 4DSOUND, who is also starting using NAP…
He will post the stack trace below!


#10

Hi,

thanks for the introduction, I’ve attached a screenshot of the stack trace, hope it helps…

This is from a freshly created project built with XCode 10.2, OSX 10.14.4

Best, Jerre


#11

Hey, The current build of the NAP package only supports XCode 10.1

@stijnvanbeek has access to source and can build a package using XCode 10.2. I did this before and managed to successfully build and run all the demos.

I am not in a position to update the downloaded package atm.


#12

In reply to my last reply (jaja) I’d like to add that a package using 10.2 loads perfectly fine in a 10.1 environment.

Cheers Coen


#13

Good to know. “Forward compatibility” so to speak.


#14

Apple, one step forward, two steps back? Also, I don’t get why XCode is updated automatically on an OSX machine, what are they thinking? The hours I have spend fixing their relentless forcing of updates. Honest aholes.


#15

Is it working for you guys to just use Xcode 10.1?

I’m on MacOS10.14.6 but downloaded Xcode 10.1 again hoping to fix everything but I still get the error:

clang: error: no such file or directory: ‘/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk/System/Library/Frameworks/OpenGL.framework’

Is there another workaround? Buy a new laptop ? :anguished:


#16

Ah, I fixed it by deleting /bin and /Xcode folders from my project and regenerating. :sweat_smile:


#17

Hey!

What version of NAP are you using? For the latest NAP (0.3) we recommend XCode 10.3 and Mojave :slight_smile: